WHICH DEVICES ARE BYJU'S PRODUCTS COMPATIBLE WITH?

BYJU’S products are compatible with most iPads, select iPhones, and Amazon Fire tablets.

Click HERE To find out which iPads and Fire Tablets are compatible with OSMO products. 

Apple iPads: Please note that Magic Workbooks are not currently compatible with the following iPad models released in the Fall of 2022; compatibility expected by mid 2023: iPad 10th Gen, iPad Pro 11” (4th Gen), and iPad Pro 12.9” (6th Gen)

Full Compatibility

Requires Reflector for iPad (2021)

Incompatible/Limited Compatibility*

iPad (Gen 5 - 9)

 

iPad 2

iPad Mini (Gen 4 - 6)*

Mini 6

iPad 3

iPad Air (Gen 2 - 5)

Air 4 - 5

iPad 4

iPad Pro 9.7-inch

 

iPad Air 1

iPad Pro 10.5-inch

 

iPad Mini 1-3

iPad Pro 11-inch (Gen 1 - 3)

Gen 1 - 3

*The tablets listed are no longer compatible, no longer being supported, and/or are considered obsolete by Apple.

If you have previously downloaded Osmo apps on one of these devices, they should continue to work. However, they will not receive new updates or content and if you delete the app, you will not be able to download it again. As a result, we are unable to provide technical support for these models.

iPad Pro 12.9-inch (Gen 1 - 5)

Gen 3 - 5

We will continue updating Osmo software to work with new iPad models as they are released.

iOS Version: The minimum iOS version required is 13

Apple iPhones:

Compatible Not compatible

 iPhone 12

 iPhone 14 Pro

 iPhone 12 Pro

 iPhone 14 Pro Max

 iPhone 12 Pro Max

 iPhone 12 Mini

 iPhone 13

 iPhone 13 Mini

 iPhone 13 Pro

 iPhone SE 2

 iPhone 13 Pro Max

 iPhone SE 3

 iPhone 14

 11 series and older

 iPhone 14 Plus

 

iOS Version: The minimum iOS version required is 13.

*All compatible iPhones will require the Osmo iPad base and the Osmo Reflector for iPad (2021).

Fire Tablets: Please note that Magic Workbooks are not currently compatible with the Fire 7 (12th Gen, 2022), Fire HD 8 (12th Gen, 2022), Fire HD 10 (13th Gen, 2023), and Fire Max 11 (13th Gen, 2023).

Full Compatibility

Requires Reflector for Fire Tablets (2021)

Incompatible/Limited Compatibility*

Amazon Fire HD 8 (10th Gen)

All Amazon 7th Generation Devices

Amazon Fire HD 8 Plus (10th Gen)

Amazon Fire 7 (9th Gen)

Amazon Fire HD 10 (9th Gen)

 

Amazon Fire 8 HD (8th Gen)

Amazon Fire HD 10 (11th Gen)

*The tablets listed are no longer compatible, no longer being supported, and/or are considered obsolete by Amazon.

If you have previously downloaded Osmo apps on one of these devices, they should continue to work. However, they will not receive new updates or content and if you delete the app, you will not be able to download it again. As a result, we are unable to provide technical support for these models.

Amazon Fire HD 10 Plus (11th Gen)

Please also note that Osmo base for Amazon Fire is not compatible with kid-proof cases or any other protective cases. All cases will need to be removed from the tablet before placing the tablet in the Osmo base.

Fire OS Version: The minimum Fire OS version required is 7.0

To improve your play experience, make sure your device meets these memory requirements.

Can’t find your answer in our support center? Contact us directly.